====== FreeNAS - NIC not recognized ======
ifconfig
Only showing **re0**.
----
===== Check the output of dmesg =====
dmesg | grep net
----
===== Check if Kernel Drivers are loaded =====
kldstat
returns:
Id Refs Address Size Name
1 75 0xffffffff80200000 2566f28 kernel
2 1 0xffffffff82768000 100ee8 ispfw.ko
3 1 0xffffffff82869000 fa60 ipmi.ko
4 2 0xffffffff82879000 2d70 smbus.ko
5 1 0xffffffff8287c000 32cc8 if_bnxt.ko
6 1 0xffffffff828af000 2243e8 if_qlxgbe.ko
7 1 0xffffffff82ad4000 f1440 ocs_fc.ko
8 1 0xffffffff82bc6000 22150 smartpqi.ko
9 1 0xffffffff82be9000 8a40 freenas_sysctl.ko
10 1 0xffffffff82e19000 330048 vmm.ko
11 1 0xffffffff8314a000 a84 nmdm.ko
12 1 0xffffffff8314b000 2ec dtraceall.ko
13 9 0xffffffff8314c000 39a78 dtrace.ko
14 1 0xffffffff83186000 5c0 dtmalloc.ko
15 1 0xffffffff83187000 1898 dtnfscl.ko
16 1 0xffffffff83189000 1d61 fbt.ko
17 1 0xffffffff8318b000 53240 fasttrap.ko
18 1 0xffffffff831df000 bcc sdt.ko
19 1 0xffffffff831e0000 6af0 systrace.ko
20 1 0xffffffff831e7000 6ac8 systrace_freebsd32.ko
21 1 0xffffffff831ee000 f9c profile.ko
22 1 0xffffffff831ef000 39f4 geom_multipath.ko
23 1 0xffffffff831f3000 14320 hwpmc.ko
24 1 0xffffffff83208000 7140 t3_tom.ko
25 2 0xffffffff83210000 aa8 toecore.ko
26 1 0xffffffff83211000 f8d0 t4_tom.ko
It could be that the network driver that is needed is not loaded.
**NOTE:** Some drivers, such as **if_igb** is nowadays compiled into the kernel, so not needed as a module, so this will not appear in the list.
So even if the driver is not seen, this does not necessarily mean this is the problem.
----
===== Load Drivers =====
Try the following drivers:
* igp
* em
----
===== Try load em driver =====
Load the **em** driver as a module at boot time by placing the following line in **/boot/loader.conf**.
if_em_load="YES"
**NOTE:** There are other tunables too.
See https://www.freebsd.org/cgi/man.cgi?query=em&sektion=4
Then reboot and see if that makes a difference.
----
===== Try load intel igp driver =====
It may be that the **igp** driver is not loaded.
The **igb** driver supports Gigabit Ethernet adapters based on the Intel 82575 and 82576 controller chips:
* Intel Gigabit ET Dual Port Server Adapter (82576)
* Intel Gigabit VT Quad Port Server Adapter (82575)
* Intel Single, Dual and Quad Gigabit Ethernet Controller (82580)
* Intel i210 and i211 Gigabit Ethernet Controller
* Intel i350 and i354 Gigabit Ethernet Controller
**WARNING:** The **igb** driver is often complied into the FreeNAS kernel so these next steps might not work.
If this does not work then just comment out the loading of the "igp" driver within **/boot/loader.conf** file.
Place the following line in **/boot/loader.conf**:
if_igb_load="YES"
**NOTE:** There are other tunables too.
See https://www.freebsd.org/cgi/man.cgi?igb(4)
**NOTE:** You might need to reboot to be certain the driver is loaded.
You could also try to load it manually:
kldload if_igb
Check if the driver is loaded
kldstat
returns:
root@freenas2:/ # kldstat
Id Refs Address Size Name
1 75 0xffffffff80200000 2566f28 kernel
2 1 0xffffffff82768000 100ee8 ispfw.ko
3 1 0xffffffff82869000 fa60 ipmi.ko
4 2 0xffffffff82879000 2d70 smbus.ko
5 1 0xffffffff8287c000 32cc8 if_bnxt.ko
6 1 0xffffffff828af000 2243e8 if_qlxgbe.ko
7 1 0xffffffff82ad4000 f1440 ocs_fc.ko
8 1 0xffffffff82bc6000 22150 smartpqi.ko
9 1 0xffffffff82be9000 8a40 freenas_sysctl.ko
10 1 0xffffffff82e19000 330048 vmm.ko
11 1 0xffffffff8314a000 a84 nmdm.ko
12 1 0xffffffff8314b000 2ec dtraceall.ko
13 9 0xffffffff8314c000 39a78 dtrace.ko
14 1 0xffffffff83186000 5c0 dtmalloc.ko
15 1 0xffffffff83187000 1898 dtnfscl.ko
16 1 0xffffffff83189000 1d61 fbt.ko
17 1 0xffffffff8318b000 53240 fasttrap.ko
18 1 0xffffffff831df000 bcc sdt.ko
19 1 0xffffffff831e0000 6af0 systrace.ko
20 1 0xffffffff831e7000 6ac8 systrace_freebsd32.ko
21 1 0xffffffff831ee000 f9c profile.ko
22 1 0xffffffff831ef000 39f4 geom_multipath.ko
23 1 0xffffffff831f3000 14320 hwpmc.ko
24 1 0xffffffff83208000 7140 t3_tom.ko
25 2 0xffffffff83210000 aa8 toecore.ko
26 1 0xffffffff83211000 f8d0 t4_tom.ko
kldstat reports that **if_igb** isn't loaded, so it must be compiled in.
----
===== References =====
https://www.freebsd.org/cgi/man.cgi?igb(4)
https://www.freebsd.org/cgi/man.cgi?query=em&sektion=4